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Access Siemens PLCs and their
VIPA equivalents through an
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This short guide explains how to access an Siemens PLC remotely 
through Talk2M and a pre-configured eWON. Applications include 
remote servicing of PLC-controlled equipment.
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1. Objective
The objective of this document is to access remotely a Siemens PLC assuming that 
configuration tasks have been done (*).

Accessing an existing setup remotely implies the following steps :

1. Opening the VPN tunnel

2. Mapping the PLC with your SIMATIC Step7®i software

3. Accessing your PLC through the Internet

(*) as per AUG-037-0-EN (Remote Access for Siemens® S7-300 & 400 PLCs, and 
their VIPA equivalents S300 - SPEED7.) 
http://wiki.ewon.biz/@api/deki/files/909/=AUG-037-0-EN-
(Remote_Access_for_Siemens_S7-300%2526400_PLCs).pdf  

2. Hardware and software requirements

 2.1 Hardware requirements
In order to follow this guide you'll need:

 PC suitable to connect to the Internet

 Internet connection

 Configured remote setup including eWON and Siemens PLC.

 2.2 Software requirements
 eCatcher  – VPN tunneling utility

http://support.ewon.biz/softwares.htm 

 Talk2M – have a valid user account at disposal

 SIMATIC Step7® software. The version of the SIMATIC Step7® software must 
allow the use of the TCP/IP interface (version 5.3 or higher).

Note: for VIPA users, we assume the use in combination with SIMATIC Step7®. 
Achieving the same tasks in combination VIPA's software WinPLC7 is feasible but
not documented here.

http://support.ewon.biz/softwares.htm
http://wiki.ewon.biz/@api/deki/files/909/=AUG-037-0-EN-(Remote_Access_for_Siemens_S7-300%2526400_PLCs).pdf
http://wiki.ewon.biz/@api/deki/files/909/=AUG-037-0-EN-(Remote_Access_for_Siemens_S7-300%2526400_PLCs).pdf


Network diagram Chapter 3.

3. Network diagram 

1. From a computer running your PLC programming software you will interact with a PLC in 
the field just as if you were using a point-to-point connection

2. Using the local gateway to Internet and the eCatcher software, you will “see” the eWON as 
part of your local network

3. You will create your VPN tunnel on the Internet using your Talk2M account

4. This will allow you to seamlessly pass the remote firewall and safely reach the eWON using 
the local LAN

5. The eWON will allow you to access the PLC transparently, indifferently whether it is hooked 
using the serial or the Ethernet link

6. You take control over the remote PLC
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4. Opening the VPN tunnel
1. Make sure you have installed the eCatcher application from 

http://support.ewon.biz/softwares.htm.

2. Start your eCatcher application, login using the credentials of the Talk2M account in which 
the eWON was created:

3. The application shows the eWON available for tunneling (*). At this point you only “see” the 
ones available on your account but you do not yet have the VPN connection required to 
access the PLC.

(*) Only eWON that are “online” (green icon) are “ready” for tunneling. An eWON with no 
icon or with red icon is not online. It can be either a GPRS/EDGE device that first needs to 
be waked up or a device that is simply not available for the moment.

4. Make sure your eWON is “online”, select it and click Connect to create the VPN tunnel: 

...wait a couple of seconds for Talk2M to create the route. As soon as the route is created, 
the connected eWON appears in the upper part of the window:
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4. Opening the VPN tunnel

5. You are now connected to the eWON through the VPN tunnel.
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5. PLC software mapping configuration
The objective of this step is to configure the PLC communication driver to use the remote 
connection instead of (or in addition to) the local connection.

 5.1 Common steps for MPI and Ethernet ISOTCP link
2. Start SIMATIC Step7® and open your existing or new PLC project. Select Options, Set 

PG/PC Interface...
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- Tips -

As of firmware v12, there is a PLC Discovery feature inside the eWON. This allows 
the automatic discovery of PLC (ISOTCP linked to the eWON) on the network while 
you are connected through Talk2M. No need to set the IP of the PLC in the same 
range than the IP of the eWON.

For more information, please refer to AUG-070: PLC Discovery through Talk2M

If firmware version is lower than 12, please follow the procedure hereunder.

https://ewon.biz/sites/default/files/aug-070-0-en-plc_discovery_through_talk2m.pdf


5. PLC software mapping configuration

3. Select the TCP/IP interface that you are using on your PC and click OK.
In the first example below we chose the TCP/IP(Auto) interface, but depending on your 
machine, you might have to select TCP/IP(Auto) →+ hardware identifier (2d example).

4. Click on the Properties... button to show up the properties of the selected interface. Open 
the IE-PG Access tab and select Do not assign IP addresses automatically.

5. Click OK to close the properties page. Back on the Set PG/PC Interface window, click OK 
to set the PC/PG interface.

6. Click OK to accept the changes. 
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5. PLC software mapping configuration

Note: For MPI go ahead with the steps below. For ISOTCP Link, end of PLC mapping.

 5.2 Additional steps for MPI local link only
If you use an Ethernet connection between the eWON and your PLC, then the PLC software 
mapping configuration ends here. You can directly establish the remote connection as 
explained in the chapter 8.
If you connect to the PLC using the MPI or Profibus link, then follow the steps explained 
hereunder: 

7. Download one of the following config files from our support web site  
(http://support.ewon.biz/ewon_cfg.htm).

 eWON.cfg - eWON gateway station file for Step7®
if you run SIMATIC on a PC that does not feature WinCC.

 eWON_WinCC.cfg - eWON gateway station file for Step7® (with WinCC installed)
if you run SIMATIC on a PC that features WinCC.
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5. PLC software mapping configuration

8. Open the Network Configuration NetPro utility of your Step7®  project.

You can access NetPro either by clicking the icon....

… or by selecting the menu options Options → Configure Network...
you obtain the NetPro network layout window shown below:

9. Import the eWON gateway station file you downloaded just before. Access path is Edit and 
Import. Browse to select either the eWON.cfg file (without WinCC) or eWON_WinCC.cfg 
(with WinCC) and click OK. 

Note: the Export file to a station needs to be selected, though the notion of export is 
confusing while you will actually be importing a device configuration.
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5. PLC software mapping configuration

10. The eWON gateway will now be displayed in your network layout:

Note: If you have problems importing one of the config files, refer to appendix 1 of Technote 29 
explaining how to create the eWON gateway station file for Step7® with NetPro from scratch.

11. Click on the red square of the eWON and drag it to the MPI network of your S7 PLC to link 
the MPI interface of the eWON to the MPI network.

12. Open the MPI interface of the eWON by a double-click on the red square and check if the 
MPI address, the transmission rate and the Subnet-ID are correctly set. (Use the 
Properties... button for more details). Click OK twice to close the two Properties windows
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5. PLC software mapping configuration

13. Double-click on the green square of the eWON to configure the Ethernet Interface of the 
Gateway.

As shown in the snapshot, do not check Set MAC address / use ISO protocol.

In the IP address field, enter the IP address of the eWON which will be used for the remote 
connection (in our example 192.168.0.53). For the Subnet mask enter the mask corresponding
to the IP address you specified for the eWON (in our example 255.255.0.0). 

Note: In some cases Step7 rejects Subnet masks he finds inconsistent and forces you to 
accept for example 255.255.255.0: you can accept while it will not harm the connection 
capability.

If you want, you can edit the name of the Ethernet by clicking Properties.
Click OK twice to close the two Properties windows.
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5. PLC software mapping configuration

14. You will now add a PG/PC Station to the network layout using the path Insert → Network 
Objects of NetPro. Double-click on the PG/PC Station. An unconnected PG/PC station is 
now added in the network pane:

15. Right click the PG/PC and click on
Object Properties... and select
the Interfaces tab and click New.
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5. PLC software mapping configuration

16. Select  Industrial Ethernet, and click OK.

17. In the parameter tab,
make sure the Set MAC
address / use ISO
protocol is NOT
selected. - Set the IP
address and the subnet
mask of your PC. Check
the Do not use router 
box. In the Subnet
window on the bottom of
the page select the
network on which the
eWON is connected to:
in our example we
named it eWON
Gateway Ethernet. Click
OK twice to close the two
Properties windows.

18. Your network layout should now look like this:
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5. PLC software mapping configuration

 

19. You will now have to assign the
PG/PC interface. To do this, right
click the PG/PC picture and click
on Assign PG/PC.

20. The Assignment tab of the Properties -PG/PC wizard appears:

In the Interface Parameter Assignments in the PG/PC select the TCP/IP interface you are 
using to connect to the Ethernet. In our example it is TCP/IP(Auto), needs to be consistent with 
point 3 above. Click the Assign button.

Note: in some cases, the  message
shown on the right may be displayed:

You can Ignore this message and click 
OK.
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5. PLC software mapping configuration

21. Verify that the Assigned Interface is the Ethernet card and click OK. Your network layout is 
now looking like this:

Note: The yellow link on top of the PG/PC shows that this object will be used to go out on 
the network. The orange background behind the other objects are meant to warn the user 
that his last changes have not been saved and compiled yet. 

22. You will now have to compile and save the network layout of your project. This is achieved 
by following the Network → Save and Compile... path in NetPro.
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5. PLC software mapping configuration

23. Select Compile and check everything if you want to have NetPro reporting errors 
(recommended if this is your first experience). You can select Compile changes only if you
feel confident that everything is alright. Click OK.

24. After compilation a popup will be displayed to inform you if the compilation was done with 
success or not. Warning messages are informative only and may usually be discarded. 
Only error messages reflect real network configuration problems.

25. The network layout of your project should now looks like this:

26. You can close the NetPro window

27. End of PLC software mapping configuration
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5. PLC software mapping configuration

6. Accessing your PLC through SIMATIC STEP7®
1. Establish the Talk2M VPN tunnel towards the eWON using eCatcher

2. Start SIMATIC STEP7®

3. Open your project and make sure you can connect with the PLC by running one of the  
tasks requiring communication like for example, right click on the CPU in the object tree, 
select PLC > Set Time of Day. 

4. Now you can check that the actual date/time returned by the PLC internal clock. (under 
Module time). If the connection is OK, this date/time should be incrementing. 

5. Your setup is now connected and ready to work in remote programming mode. 

6. Once you finished your work with SIMATIC STEP7®:

● terminate the SIMATIC Step7® connection through View > Offline and close the 
application. 

● Close the Talk2M connection (VPN tunnel) by clicking Disconnect in eCatcher. 
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6. Accessing your PLC through SIMATIC STEP7®

Note: If the eWON is connected to the Internet using a GPRS/Edge modem, you may want 
to disconnect it to save connection costs. To close the line, you have to use the Go offline 
button which is displayed on the context menu when you right-click the eWON in the eWON
list.

7. End of Accessing your PLC through SIMATIC STEP7® 
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Revision history

Revision Level Date Description

1.0 08/09/11 First issue

1.1 15/12/16 Added “PLC Discovery” to Chapter 5

i SIMATIC® and SIMATIC Step7®  are registered trademarks of Siemens.

Document build number:  10

Note concerning the warranty and the rights of ownership:

The information contained in this document is subject to modification without notice. The vendor
and the authors of this manual are not liable for the errors it may contain, nor for their eventual 
consequences.

No liability or warranty, explicit or implicit, is made concerning quality, the accuracy and the  
correctness of the information contained in this document. In no case the manufacturer's responsibility could 
be called for direct, indirect, accidental or other damage occurring from any defect of the product or errors 
coming from this document.

The product names are mentioned in this manual for information purposes only. The trade marks 
and the product names or marks contained in this document are the property of their respective owners.

This document contains materials protected by the International Copyright Laws. All reproduction
rights are reserved. No part of this handbook can be reproduced, transmitted or copied in any way without 
written consent from the manufacturer and/or the authors of this handbook

eWON sa, Member of ACT'L Group. 
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